Service Disruption - Limited Site Functionality

Incident Report for uShip

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 10:39 CST

Identified

The issue has been identified. Our team is actively working on a fix and we expect to restore full service shortly.
Posted Dec 02, 2025 - 10:23 CST

Update

We are continuing to investigate this issue.
Posted Dec 02, 2025 - 10:10 CST

Investigating

We are currently experiencing intermittent issues affecting several areas of our platform, including search, LTL shipping tools, My Shipments, and other core functionality. Our team is actively investigating and working to restore full service as quickly as possible.We apologize for any inconvenience and will provide updates as more information becomes available.
Posted Dec 02, 2025 - 10:10 CST
This incident affected: Web Interface and Mobile Apps.